Эллементы массива вычисляются по формуле a(x,y)=2x^2-y^2 написать программу, которая выводит на экран значения элементов массива а(2,2). подсчитать количество отрицательных элементов сумму положительных элементов выводит на экран номера всех элементов, значения которых =0
Проверено - работает на Паскаль АВС.
Кстати, похоже на какую-то ошибку в условии задачи: по формуле A(X,Y)=2X^2-Y^2 ни один элемент массива никогда не будет равен 0.
Program Lobu;
uses crt;
const n=2;
var
a:array[1..n,1..n] of real;
neg,sum: real;
i,j:integer;
begin
writeln('*** alphaues is thinking... ***');
writeln('*** OK ***');
neg:=0;
sum:=0;
for i:=1 to n do
begin
for j:=1 to n do
begin
a[i,j]:=2*i*i-j*j;
write (a[i,j]:7:2);
if a[i,j]<0 then neg:=neg+1;
if a[i,j]>0 then sum:=sum+a[i,j];
if a[i,j]=0 then writeln('Элемент А(',i,',',j,') равен 0');
end;
writeln();
end;
writeln();
writeln('Количество отрицательных чисел ',neg);
writeln('Сумма положительных чисел ',sum);
end.