В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Дорожная карта у программиста Васи записана как матрица смежности графа. Напишите программу, которая Васе определить, верно ли, что из первого города можно проехать во все остальные (не обязательно напрямую).

Входные данные
В первой строке вводится количество городов на карте N ( 1 ≤ N ≤ 1000 ). В следующих N строках записано по N чисел, разделённых пробелами – элементы матрицы смежности графа, который описывает схему дорог.

Выходные данные
Программа должна вывести слово 'YES', если из первого по порядку города можно проехать во все остальные, и 'NO', если это не так.

входные данные
5
0 1 1 1 0
1 0 1 0 1
1 1 0 1 0
0 0 0 0 0
0 1 0 1 0
выходные данные
YES

-

входные данные
5
0 1 1 0 0
1 0 1 0 0
1 1 0 0 0
0 0 0 0 1
0 0 0 1 0
выходные данные
NO

Показать ответ
Ответ:
LetMaria
LetMaria
12.03.2023 05:00
// PascalABC.NET 3.3

begin
  var a:=ArrRandom(10,-50,50);
  writeln('1)');  a.Println;
  writeln('Среднее арифметическое четных элементов = ',
           a.Where(x->x mod 2=0).Average);
  var c:=ArrRandom(10,-50,50);
  writeln('2)');  c.Println;
  writeln('max+min = ',c.Max+c.Min);
  writeln('3)');
  var n:=ReadInteger('n =');
  var b:=SeqGen(n,random(5),x->x+random(1,5)).ToArray;
  b.Println;
  var s:=ReadInteger('s =');
  var k:=b.Where(x->x<s).Count;
  b:=b[:k]+Arr(s)+b[k:];
  b.Println;
end.

Пример:
1)
-24 12 -31 -5 -45 36 27 43 46 -6
Среднее арифметическое четных элементов = 12.8
2)
24 -13 -20 -47 16 27 -33 11 22 -33
max+min = -20
3)
n = 10
0 4 5 7 11 15 19 20 24 25
s = 10
0 4 5 7 10 11 15 19 20 24 25
0,0(0 оценок)
Ответ:
dianahaliullina1
dianahaliullina1
16.06.2022 18:53
#include <iostream>
#include <fstream>
#include <string>
#include <vector>
#include <iterator>
using namespace std;  
int main()
{
     vector<string> str;
     string text;
     ifstream fin("a.txt");
     while (getline(fin, text)) {
         str.push_back(text);
     }
     fin.close();
     str.erase(str.begin() + 2);
     ofstream fout("b.txt");
     copy(str.begin(), str.end(), ostream_iterator<string>(fout, "\n"));
     fout.close();
     system("pause");
     return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота