В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
angelinafeodoro
angelinafeodoro
16.07.2020 03:05 •  Информатика

до 19:00 по мск

1. Напишите программу, запрашивающую у пользователя пароль. Если пароль не совпадает с эталонным (придумайте его сами например, "12345"), то программа возвращает пользователя на шаг ввода пароля. данная программа должна быть выполнено с оператора Repeat...Until

2. Напишите программу викторину, которая задаёт три во и предлагает пользователи на них ответить. Переход на следующий во не происходит до тех пор, пока пользователь не ответит правильно на предыдущий во Переменную под ответа используйте текстовую (string). данная программа должна быть выполнено с оператора Repeat... Until.​

Показать ответ
Ответ:
radich16
radich16
13.03.2020 13:34
Задание 1
Информационный объем I = 44100 Гц * 5 * 60 с * 16 бит = 211680000 бит = 26460000 байт = 25839,84375 Кбайт = 25,23422241210938 Мбайт

Задание 2
I = 1,3 Мбайт t = 1 мин Частота дискретизации v = 1,3 * 1024 * 1024 * 8 бит / 60 с / 8 бит = 22719,147 Гц

Задание 3
I = 5.1 Мбайт, t = 2 минуты, v = 22050 Гц Разрядность аудиоадаптера i = 5.1 * 1024 * 1024 * 8 бит / (2 * 60) с / 22050 Гц = 16,1685 бит (округленно 16 бит)

Задание 4
I = 0.01 Гбайт, i = 16 бит, v = 44100 Гц Время t = 0,01 * 1024 * 1024 * 1024 * 8 бит / 16 бит / 44100 Гц = 121 с (округляем до 120 с)
0,0(0 оценок)
Ответ:
ЭлькаЭля
ЭлькаЭля
24.01.2023 22:59

Чтобы решить эту задачу, воспользуемся методом программирования:

1) напишем функцию, которая получает число в качестве аргумента и моделируя процесс преобразивания из условия возвращает результат:

int f(int n){

   int d[4];

   for(int i = 0; i < 4; i++){

       d[3 - i] = n % 10;

       n /= 10;

   }

   int u = d[0] + d[3], v = d[1] + d[2];

   string res;

   u < v ? res += to_string(u) + to_string(v) : res += to_string(v) + to_string(u);

   return stoi(res);

}

2) так как нам нужно найти наибольшее четырехзначаное число, дающее результат 815, то запускаем цикл, идущий от самого большого четырехзначного числа(9999) до самого маленького(1000), и как только нам встретится число, дающее в результате нужное число(815), выведем его в консоль, и закончим работу программы, то, что выведет программа и будет ответом:

полный код(результат работы на фото) :

#include <iostream>

using namespace std;

int f(int n){

   int d[4];

   for(int i = 0; i < 4; i++){

       d[3 - i] = n % 10;

       n /= 10;

   }

   int u = d[0] + d[3], v = d[1] + d[2];

   string res;

   u < v ? res += to_string(u) + to_string(v) : res += to_string(v) + to_string(u);

   return stoi(res);

}

int main(){

   for(int i = 9999; i >= 1000; i--){

       if(f(i) == 815){

           cout << i;

           return 0;

       }

   }

}

ответ: 9806


Автомат получает на вход четырёхзначное число. По этому числу строится новое число по следующим прав
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота