В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
алия256
алия256
29.03.2020 01:59 •  Информатика

Для заданного одномерного массива с компонентами вещественного типа написать программу решения : вычислить разность между наибольшим и наименьшим элементом.

Показать ответ
Ответ:
guyfdfff55
guyfdfff55
11.06.2020 12:16

program fnued;

uses crt;

var a:=array [1..1000] of integer;

      i,n,max,min,r:real;

begin

clrscr;

readln(n);

for i:=1 to n do

readln(a[i]);

min:=a[1];

max:=a[1];

for i:=1 to n do

if a[i]>max then max:=a[i];

for i:=1 to n do

if a[i]<min then min:=a[i];

r:=max-min;

writeln(r);

readln;

end.

 

0,0(0 оценок)
Ответ:
Kakady0071
Kakady0071
11.06.2020 12:16


program massiv;
var
a:array[1..10] of integer;
i,b,c : integer;
begin
writeln ('posledovatelno vedity elementi massiva (10 chisel)');
for i:=1 to 10 do
readln(a[i]);
b:=a[1];
for i:=1 to 10 do
begin
if a[i]>b then
b:=a[i];
end;
c:=a[1];
for i:=1 to 10 do
begin
if a[i]<c then
c:=a[i];
end;
writeln('raznost mesdu naibolshim i naimenshim elementom massiva =',b-c);
readln;
end.

p.s если нужны пояснения то в личку

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота