Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
оксана731
02.01.2022 01:58 •
Информатика
Дано простое число. найти следующее за ним простое число.программа паскаль
Показать ответ
Ответ:
ninikogordu
08.09.2020 11:55
Var
a,i,b:integer;
begin
readln(a);
while (b>0)
begin
for i:=2 to a
begin
if ((a mod i)=0) then b:=b+1;
end;
a:=a+1;
end;
writeln(a);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
makusolka
01.11.2020 18:10
Дан целочисленный массив А[1.3, 1.2]. Вывести на экран элементы массива, кратные 5 и их индексы...
karipovilna
21.03.2023 16:41
Кто-нибудь написать прогу в С++ 1.Написать программу: Пользователь вводит с клавиатуры число х Программа должна посчитать у по формуле и вывести значение у на экран 2.Написать...
mashav882
18.10.2020 04:31
Какое количество информации несёт в себе сообщение об одном из двух равновероятных результатов некоторого события?...
юра419
12.08.2022 13:06
Как можно глухому человеку,если он не слышит телефонный звонок?...
Skotonyaka
12.08.2022 13:06
Вчера настина мама купила n апельсинов. сегодня утром их уже не было. настя точно помнит, что съела апельсинов на f меньше, чем папа, и на m больше, чем мама, и хочет...
Krisitnka
27.05.2021 07:02
Когда и где родился матвеев мотросов...
zverrodion199911
27.09.2022 22:11
Яким документом керувався І.Скоропадський...
кот931
14.09.2021 04:25
Що змінили монголи в тактиці, рухаючись землями Галичини і Волині? пліз...
lcjewfyjozo075
13.06.2020 18:09
3) Напишіть, яка держава становила основну зовнішньополітичну загрозу для Галицько- Волинської держави у другій половині XIII ст. Як це вплинуло на розвиток держави?...
ArinaKosareva63
11.09.2020 08:34
Укажите вариант в котором частица не употреблена с глаголом (Не) чего было утром делать – мы шли на пляж самого фиолетового в космосе моря.Вы узнаете, что вызывает солнечное...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
a,i,b:integer;
begin
readln(a);
while (b>0)
begin
for i:=2 to a
begin
if ((a mod i)=0) then b:=b+1;
end;
a:=a+1;
end;
writeln(a);
end.