В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
AdelinaAries
AdelinaAries
23.03.2023 15:26 •  Информатика

"дана строка символов t. напишите программу, которая добавит перед и после каждой гласной буквой строки – букву ‘p’. например, ‘corectitudine’ станет ‘’. "написать на c++

Показать ответ
Ответ:
Lera11111111100000
Lera11111111100000
07.10.2020 09:17
#include <iostream>
#include <set>
 
using namespace std;
int main()
{
 string t, s="";
 cout << "t = ", cin >> t, cout << endl;
 set<char> a = {'a','e','i','o','u','y'};
 for(int i=0; i<t.length(); i++)
  if(a.find(t[i]) == a.end()) s = s+t[i];
  else s = s+'p'+t[i]+'p';
 cout << s << endl;
 return 0;
}

Пример:
t = corectitudine
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота