В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
England1111
England1111
06.09.2022 18:04 •  Информатика

Дан прямоугольный массив целых положительных чисел 10 х 20. опишите на языке или на одном из языков программирования алгоритм поиска строки с наименьшей суммой элементов. вывести на печать номер строки и сумму ее элементов.
предполагается, что такая строка единственна. составить программу в

Показать ответ
Ответ:
marshaldir80
marshaldir80
23.05.2020 18:20

program xxx;

  var i, j, k, min : integer;

        a:array[1..10, 1..20] of integer;

        b:array[1..10] of integer;

begin

   for i:=1 to 10 do

     for j:=1 to 20 do

        readln(a[i,j]);

   for i:=1 to 10 do

    begin

     b[i]:=0;

     for j:=1 to 20 do

       b[i]:=b[i]+a[i,j];

    end;

   min:=b[1]; k:=1;

   for i:=2 to 10 do

     if b[i]<min then begin max:=b[i]; k:=i end;

   writeln('наименьшая сумма элементов =', min);

   writeln('она находится в строке -', k);

   readln

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота