Дан массив из 10 целых чисел. определите, сколько элементов этого массива имеют максимальное значение. надо написать на паскале, объяснить при этом всё, ещё и блок схему надо
Var m:array[1..10] of integer; i,max,cnt:integer; begin max := -1000; write('Massive: '); for i := 1 to 10 do begin m[i] := random (11)-5; write(m[i],' '); if m[i] > max then begin inc(cnt); max := m[i]; end; end; writeln; writeln('Максимальное число: ',max); writeln('Всего максимальных чисел: ', cnt); end.
Var m:array[1..10] of integer; i,max,cnt:integer; begin max := -1000; write('Massive: '); for i := 1 to 10 do begin m[i] := random (11)-5; write(m[i],' '); if m[i] > max then begin inc(cnt); max := m[i]; end; end; writeln; writeln('Максимальное число: ',max); writeln('Всего максимальных чисел: ', cnt); end.
begin
max := -1000;
write('Massive: ');
for i := 1 to 10 do begin
m[i] := random (11)-5;
write(m[i],' ');
if m[i] > max then begin inc(cnt); max := m[i]; end;
end;
writeln;
writeln('Максимальное число: ',max);
writeln('Всего максимальных чисел: ', cnt);
end.
begin
max := -1000;
write('Massive: ');
for i := 1 to 10 do begin
m[i] := random (11)-5;
write(m[i],' ');
if m[i] > max then begin inc(cnt); max := m[i]; end;
end;
writeln;
writeln('Максимальное число: ',max);
writeln('Всего максимальных чисел: ', cnt);
end.