В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
StayStr0g
StayStr0g
08.03.2021 04:50 •  Информатика

Дан массив c(m). найти отношение максимального к минимальному элементу. написать программу в pascal,

Показать ответ
Ответ:
MarusiaG
MarusiaG
26.06.2020 12:49

const m=10;

var c:array[1..m] of integer;

max,min,i,j: integer;

begin

writeln('Массив:');

for i:=1 to m do

begin

c[i]:=random(50);

write(c[i],' ');

end;

writeln;

max:=c[1];

min:=c[1];

for i:=2 to m do

begin

if c[i]>max then max:=c[i];

if c[i]<min then min:=c[i];

end;

writeln('max = ',max,' min = ',min,' max/min = ',max/min:5:2);

end.

Пример:

Массив:

27 29 35 42 30 42 27 42 21 31  

max = 42 min = 21 max/min =  2.00

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота