В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Соломія2203
Соломія2203
17.12.2022 12:52 •  Информатика

Дан фрагмент программы, определяющий количество отрицательных элементов массива A[1..10]. Восстановите пропущенное условие k:=10;
for i:=1 to 10 do
if then k:=k – 1;
write (k)
Выберите один ответ:
A[i] 0
A[i]>=0

Каким образом проверяется правильность разработанной программы?

Выберите один ответ:
правильность составленной программы проверяется сообщением о выявлении ошибок
правильность составленной программы проверяется с тестов
правильность составленной программы проверяется с математических соотношений между исходными данными и результатами

Сумма элементов массива вычисляется по следующей формуле

Выберите один ответ:
s:= s + a[i]
s:= s[i] + a[i]
s[i]:= s[i] + a[i]
s:= i + a[i]

Что делает следующий элемент программы?

for i:=1 to 23 do

begin

if (a[i])>3) and (a[i])<7) then

writen (a[i]);

end;
Выберите один ответ:
выводит на экран все элементы массива, если они принадлежат интервалу (3;7)
выводит на экран все элементы массива, если они принадлежат интервалу [3;7]
выводит на экран все элементы массива большие 3 или меньшие 7
выводит на экран все элементы массива, если они принадлежат интервалу (1;3)

Дан одномерный массив.

-125

200

10

0

43

11

Какой номер (индекс) у элемента массива, значение которого 0? В ответе запишите число.

Показать ответ
Ответ:
skymiss
skymiss
14.06.2020 22:06

11.01| 101

     |

     | 0.10100110011001100110011001100110011001100110011001

11

--   не делится, добавляем 0 (в частное целые 0)

110

101

---  делится (в частное десятые 1)

---  остаток 1, сносим 1 - мало, (в частное 0 - сотые), сносим 0

  110

  101

   делится (в частное тысячные 1)

   остаток 1,сносим 0-мало,(в частное 0),сносим 0-мало,(в частное 0), сносим 0

    1000

     101

      делится (в частное 1)

      остаток 11,сносим 0

      110

      101

      --- делится (в частное 1)

      --- остаток 1,сносим 0-мало,(в частное 0),сносим 0-мало,(в частное 0),сносим 0

        1000

         101

          делится (в частное 1)

          остаток 11,сносим 0

          11

        и т д

0,0(0 оценок)
Ответ:
AlinaRoz
AlinaRoz
26.03.2020 14:40

unit Unit1;

interface

uses
Windows, Messages, SysUtils, Variants, Classes, Graphics, Controls, Forms,
Dialogs, StdCtrls,Math, ExtCtrls;

type
TForm1 = class(TForm)
Button1: TButton;
Image1: TImage;
procedure Button1Click(Sender: TObject);
procedure Image1Click(Sender: TObject);
private
{ Private declarations }
public
{ Public declarations }
end;

var
Form1: TForm1;

implementation

{$R *.dfm}

procedure TForm1.Button1Click(Sender: TObject);
var
a,x,y,r:Integer;
begin
Randomize;
Image1.Picture := nil;
Image1.Canvas.Brush.Color:=clBlack;
Image1.Canvas.Rectangle (0,0,Image1.Width,Image1.Height);
Image1.Canvas.Brush.Color:=clWhite;

for a:=1 to RandomRange(9,20) do
begin
x:=RandomRange(50,1000);
r:=RandomRange(1,15);
y:=RandomRange(50,550);
Image1.canvas.Ellipse(x-r,y-r,x+r,y+r);
end;


end;
procedure TForm1.Image1Click(Sender: TObject);
begin

end;

end.

 

 

на форме image и кнопка

(если тебе нужна просто программа(как я думал изначально) напиши в почту, просто уважаемые админы удаляют мои посты :(   )

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота