В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
tdtwdgtduqgcggggc
tdtwdgtduqgcggggc
28.05.2022 21:24 •  Информатика

Дан двумерный массив целых чисел, i=10, j=15; заполняется случайными образом целыми числами от 0 до 100. определите сколько раз в нём случается элемент со значением х (х-задаётся пользователем).

Показать ответ
Ответ:
Dimo558
Dimo558
26.05.2020 02:46

a:array[1..10,1..15] of integer;

i,j,k,x:integer;

begin

read(x);

k:=0;

 

for j:=1 to 15 do

for i:=1 to 10 do

a[i,j]:=random(101);

for j:=1 to 15 do

for i:=1 to 10 do

if a[i,j]=x then k:=k+1;

 

write(k);

end.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота