В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
annaegorova4
annaegorova4
15.07.2022 12:30 •  Информатика

Целочисленный массив 30 элементов элементы массива могут принимать целые значе минус 300 до 300 включительно написать программу содержащие фото значения элементов массива с клавиатуры и вывод на экран в строку

Показать ответ
Ответ:
DragaoMad
DragaoMad
18.03.2022 04:29

 Есть сомнения в том первый элемент массива это 0.5 или же это 2 элемента 0 и 5  и тогда объявление массивов будет следующим var a:array[1..9] of integer=( 0,5,12,-18,16,13,5,8,0 );  b: array[1..9] of real;  

 

Program massiv;

Uses Crt;

var a:array[1..8] of real =(0.5,12,-18,16,13,5,8,0);

       b: array[1..8] of real; 

       sum:real

       i:integer;

begin

     clrscr;

     write('Массив B: ');

     sum:=0; 

     for i:=1 to 8 do 

         begin     

              b[i]:=a[i]/2;  

              sum:=sum+a[i]+b[i]; 

              write(b[i]:2:2);

        end; 

  writeln;

  writeln('Сумма элементов массивов а и b: ',sum);

   writeln(' Первый элемент массива а : ',a[1]:2:2);

    writeln(' Первый элемент массива b : ',b[1]:2:2); 

    readkey;

end. 

 

 

0,0(0 оценок)
Ответ:
123julia456f678
123julia456f678
14.08.2022 15:30

var

 i, n:integer;

 price:real;

begin

  n := 20;

  price := 20.4;

  for i := 1 to n do

    writeln('Стоимость ', i:3, ' ед. товара составляет ', price * i:8:2, ' руб.');

end.

 

 

//вторая задача

var

  i, f, n:integer;

begin

  f := 453;

  n := 10;

  writeln('фунты    граммы');

  for i := 1 to n do

    writeln(' ', i:2, i * f :11);

end.

 

//третья задача

var

  i, n:integer;

  k:real;

begin

  n := 20;

  writeln('Введите курс '); readln(k);

  writeln('доллары    рубли');

  for i := 1 to n do

    writeln('  ', i:2, i * k:13:2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота