В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
DenZag
DenZag
08.11.2021 12:41 •  Информатика

C ++ Уникальные элементы
Дан массив. Распечатайте только те значения элементов массива, которые встречаются в нем ровно один раз. Элементы следует распечатывать в том порядке, в котором они встречаются в массиве. Создавать новые массивы нельзя.

Входные данные

В первой строке входных данных содержится натуральное число n (n≤100) — количество элементов массива. В следующей строке содержится n натуральных чисел, не превосходящих 30000 — элементы массива.

Выходные данные

Выведите ответ на задачу.

Показать ответ
Ответ:
Granger341
Granger341
14.04.2021 23:23

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   int n;

   cin >> n;

   vector<int> v(n);

   for (int i = 0; i < n; ++i){

       cin >> v[i];

   }

   for (int i = 0; i < n; ++i){

       bool flag = false;

       for (int j = 0; j < i; ++j){

           if (v[i] == v[j]){

               flag = true;

           }

       }

       for (int j = i + 1; j < n; ++j){

           if (v[i] == v[j]){

               flag = true;

           }

       }

       if (flag == false){

           cout << v[i] << " ";

       }

   }

   return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота