В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

C++ треугольник паскаля
Треугольник Паскаля строится следующим образом. Первая строка состоит из одного числа, равного единице. Каждая следующая содержит на одно число больше, чем предыдущая. Первое и последнее из этих чисел равны 1, а все остальные вычисляются как сумма числа, стоящего в предыдущей строке над ним и числа, стоящего в предыдущей же строке слева от него.

Входные данные.
Записано одно число N (0 ≤ N ≤ 30).

Выходные данные.
Вывести N строк треугольника Паскаля.

Примечание. Все числа в треугольнике Паскаля при указанных ограничениях входят в integer.

Пример входных данных
8

Пример выходных данных понять не могу

Показать ответ
Ответ:
rotaru1930
rotaru1930
12.10.2020 12:06

#include <iostream>

using namespace std;

                   

double Cnk(int N,int K){

return ( (N<K) ? 0 : ((K==0) ? 1 : ((N-K+1) / double(K) * Cnk(N,K-1))) );

}

                 

int main(){

   int n;

   cin>>n;

for (int j = 0; j <= n; j++) {

 for (int i=0; i <=j ; i++)

  cout<<Cnk(j,i)<<" ";

 cout<<"\n";

}

   std::cin.get();

   std::cin.get();

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота