В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
danilkalmykov1
danilkalmykov1
07.05.2021 20:38 •  Информатика

Python, информатика | По данному числу n закончите фразу «На лугу пасется...» одним из возможных продолжений: «n коров», «n корова», «n коровы», правильно склоняя слово «корова».

Формат входных данных
Дано число n (n≤99).
Формат выходных данных
Программа должна вывести введенное число n и одно из слов (на латинице): korov, korova или korovy, например, 1 korova, 2 korovy, 5 korov. Между числом и словом должен стоять ровно один пробел.

Показать ответ
Ответ:
sobik21
sobik21
12.12.2020 08:30

n:integer;

begin

readln(n);

If (n >= 11) and (n <= 14) then write(n, ' korov') else

case n mod 10 of

0, 5..9: write(n, ' korov');

1: write(n,' korova');

2..4: write(n, ' korovy');

end;

end.

Объяснение: ну в вроде как-то так.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота