В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
илюхаaaaa
илюхаaaaa
10.06.2021 23:20 •  Информатика

ABCPascal Составить программу, которая каждую встреченную в заданном предложении букву «р» заменяла бы сочетанием букв «ля».

Показать ответ
Ответ:
yanaprosandeeva
yanaprosandeeva
13.01.2023 11:46

Відповідь:

program ReplaceRWithLya;

var

 inputString: string;

 outputString: string;

 i: integer;

begin

 inputString := 'Это предложение содержит несколько букв р.';

 outputString := '';

 for i := 1 to length(inputString) do

 begin

   if inputString[i] = 'р' then

     outputString := outputString + 'ля'

   else

     outputString := outputString + inputString[i];

 end;

 writeln(outputString);

end.

Пояснення:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота