В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kiscaki
kiscaki
29.06.2022 08:34 •  Информатика

Написать программу в паскале, тема массивы возвести в квадрат элементы, не превосходящие по модулю введенное с клавиатуры число r.

Показать ответ
Ответ:
Оля666Olya
Оля666Olya
09.10.2020 19:42

const n=10;

var a:array[1..n] of integer;

i,r: integer;

begin

write (' Исходный массив: ');

for i:=1 to n do

begin

a[i]:=random(41)-20;

write (a[i]:3,' ')

end;

writeln;

write ('Введите число: ');

readln (r);

write ('Преобразованый массив: ');

for i:=1 to n do

begin

if abs(a[i]) <= r then a[i]:=a[i]*a[i];

write (a[i]:3,' ')

end

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота