В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
MurMraz1
MurMraz1
10.02.2020 08:03 •  Информатика

(99 ! ) python напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов.если в массиве нет элементов с чётными положительными значениями,нужно вывести сообщение об этом.

Показать ответ
Ответ:
sasockolowa
sasockolowa
21.08.2020 12:28
mas = [int(i) for i in input('Введите массив : ').split()]
flag = 0
for i in mas:
    if i%2 == 0:
        max = min = i
        flag = 1
        break
if flag == 0:
    print('Четных нет!')
    exit()
for i in mas:
    if i%2 == 0 and i > max:
        max = i
    if i%2 == 0 and i < min:
        min = i
print(max,min) 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота