В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
semik1232
semik1232
25.06.2021 16:42 •  Информатика

75 . написать программу на языке freebasic(либо любой другой бейсик,но лучше фри).в исходной строке a$ заменить все вхождения заданного сочетания символов x$ на сочетание y$.вывести исходную и полученную строки.

Показать ответ
Ответ:
katyaadushkina3006
katyaadushkina3006
26.03.2023 01:53
Begin
  var a: integer;
  readln(a);
  for i: integer := 1 to abs(a) do
    if (a mod i = 0) then
      writeln('> ', i);
end.

function Simple(a: integer): boolean;
begin
  result := true;
  for i: integer := 2 to (a div 2) do
    if (a mod i = 0) then
     begin
      result := false;
      break;
    end;
end;

begin
  var a: integer;
  readln(a);
  writeln(Simple(a));
end.

var
  a: integer;

begin
  readln(a);
  for i: byte := length(a.ToString()) downto 1 do
    write(a.ToString()[i]);
end.

function Simple(a: integer): boolean;
begin
  result := true;
  for i: integer := 2 to (a div 2) do
    if (a mod i = 0) then
     begin
      result := false;
      break;
    end;
end;

function par(a: integer): string;
begin
  for i: byte := length(a.ToString()) downto 1 do
    result += a.ToString()[i];
end;

  
begin
  var a: integer;
  readln(a);
  for i: integer := 1 to abs(a) do
    if ((a mod i = 0) and (Simple(a)) and (par(a) = inttostr(i))) then
      writeln('> ', i);
end.
0,0(0 оценок)
Ответ:
gadukina
gadukina
27.05.2023 11:45
Var
  mas: array [,] of integer;
  i,j,m,n,s,max: integer;
  f:boolean;
begin 
write('Введите размерность массива: ');
readln(n); 
write('Введите число m: ');
readln(m);
setlength(mas,n+1,n+1);
for i:=1 to n do
  begin;
  for j:=1 to n do
    begin
    mas[i,j]:=random(-m,m);
    write(mas[i,j]:6);
    if (j>i) and (mas[i,j]=0) then s:=s+1;
    end;
  writeln;
  end;
j:=n;
f:=false;
for i:=1 to n do
  begin
  if (mas[i,j] mod 2=0) then
       begin
       if f=false then
         begin
         max:=mas[i,j];
         f:=true;
         end;
       if (mas[i,j]>max) then max:=mas[i,j];
       end;
  j:=j-1;
  end;
writeln('Число нулей над гл.диагональю: ',s);
writeln('Максимальный четный на доп.диагонали: ',max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота