Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Nurlan2010
12.04.2022 17:18 •
Информатика
Напишите подпрограмму, которая находит максимальный и минимальный элементы переданного ей динамического массива (используйте изменяемые параметры) на паскале, ввод через файл
Показать ответ
Ответ:
bereza11
20.06.2022 23:12
#include <iostream>
#include <cmath>
using namespace std;
void main()
{
int n,sum=0;
float y,k=0;
cin >> n;
int *mass = new int[n];
for (int i = 0;i < n;++i)
{
cin >> mass[i];
}
for (int i = 0;i < n;++i)
{
if (mass[i] >0 )
{
k++;
y=pow(mass[i],2);
cout<<y;
sum+=mas[i]
}
}
system("pause");
}
2)#include <iostream>
#include <cmath>
using namespace std;
void main()
{
int s,p,r,day=0;
cin >> s>>p>>r;
float km=s;
while(r>km)
{
km+=km*p/100;
day++;
}
cout << " km = " << km << " day = " << day << endl;
system ("pause");
}
0,0
(0 оценок)
Ответ:
kril20101
18.09.2021 08:02
//я писал этот унылый код полтора часа. Полтора часа, Карл! Я слишком расслабился.
#include <iostream>
using namespace std;
int k=2;
bool StrangeSeq(int n){
if (k<n){
if(n%k==0){
cout<<"false";
return false;
}
k++;
StrangeSeq(n);
}
else
{
cout<<"true";
return true;
}
}
int main(){
int n;
cin>>n;
StrangeSeq(n);
cin.get();
cin.get();
}
0,0
(0 оценок)
Популярные вопросы: Информатика
ollolinda213
02.04.2021 11:24
Паскаль. напишите логическую функцию, которая возвращает значение истина , если переданное ей число помещается в 8-битную ячейку памяти. пример работы программы: введите число: 751...
zzubaidulloieva
27.10.2021 15:02
Pascal abc. ома решил придумать свой признак делимости на 8. ома будет считать что число делится на 8 если существует перестановка цифр числа такая что новое число было без лидирующих...
ColyaBRO
12.09.2022 15:50
Дано масив дійсних чисел а[1..n], n=11 .знайти всі ті елементи , квадрати яких більші заданого числа b....
LavaGirl14
12.10.2020 11:09
решить пример 1 и пример 2...
пишитеответ
24.06.2020 22:15
Сотрудник полиции находится на одном из 16 маршрутов патрулирования.сколько бит информации содержит сообщение о том,где находится сотрудник...
3457ДашаСупер111
24.06.2020 22:15
Кто,когда и где разработал первый проект автоматической вычислительной машины?...
77788899
01.07.2022 03:32
Написать программу в паскале: заполнить двумерный массив n*n случайными числами из интервала [-10,10] и найти сумму элементов меньших элемента стоящего в к-ом столбце и l-ой строке....
daniktsarev
22.04.2021 01:56
Укажіть пари реагентів взаємодія яких відповідає йонному рівнянні реакції cu(2+)+2oh(-)=cu(oh)2а) (2) оксид та нітратна кислота; б)(2) гідроксид та сульфатна кислота ; в) (2) сульфід...
M4xL1ght
29.10.2022 11:00
Составить предложения на все случаи постановки тире между подлежащим и сказуемым....
yrik0440
23.05.2020 01:30
Как форма кружки влияет на остывание чая в ней? ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <cmath>
using namespace std;
void main()
{
int n,sum=0;
float y,k=0;
cin >> n;
int *mass = new int[n];
for (int i = 0;i < n;++i)
{
cin >> mass[i];
}
for (int i = 0;i < n;++i)
{
if (mass[i] >0 )
{
k++;
y=pow(mass[i],2);
cout<<y;
sum+=mas[i]
}
}
system("pause");
}
2)#include <iostream>
#include <cmath>
using namespace std;
void main()
{
int s,p,r,day=0;
cin >> s>>p>>r;
float km=s;
while(r>km)
{
km+=km*p/100;
day++;
}
cout << " km = " << km << " day = " << day << endl;
system ("pause");
}
#include <iostream>
using namespace std;
int k=2;
bool StrangeSeq(int n){
if (k<n){
if(n%k==0){
cout<<"false";
return false;
}
k++;
StrangeSeq(n);
}
else
{
cout<<"true";
return true;
}
}
int main(){
int n;
cin>>n;
StrangeSeq(n);
cin.get();
cin.get();
}