В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
алексей750
алексей750
19.12.2021 23:13 •  Информатика

5. в двухмерном массиве хранится информация о количестве студентов в той или иной группе каждого курса инсти¬тута с первого по пятый (в первой строке — информация о группах первого курса, во второй — второго и т. на каж¬дом курсе имеется 8 групп. составить программу для расчета общего числа студентов на любом курсе. си шарп.

Показать ответ
Ответ:
svetaelia
svetaelia
02.10.2020 15:05
Using System;

namespace Znanija {
    internal class Program {

        private static void Main() {
            var r = new Random(DateTime.Now.Millisecond);
            var course = r.Next(1, 6);
            var students = new int[5,8];

            for (var i = 0; i < students.GetLength(0); i++) {
                for (var j = 0; j < students.GetLength(1); j++) {
                    students[i, j] = r.Next(10, 40);
                    Console.Write("{0:d2} ", students[i, j]);
                }
                Console.WriteLine();
            }

            Console.WriteLine("На курсе {0} кол-во студентов = {1}", course, CountStudents(students, course));
            Console.ReadKey();
        }

        private static int CountStudents(int[,] students, int course) {
            if (students.GetLength(0) < course) {
                Console.ForegroundColor = ConsoleColor.Red;
                Console.WriteLine("Нет курса " + course);
                return 0;
            }

            var number = 0;
            for (var i = 0; i < students.GetLength(0); i++) {
                number += students[course - 1, i];
            }

            return number;
        }

    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота