В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
DeathStroke11
DeathStroke11
01.07.2020 16:34 •  Информатика

3. только чётные! напишите программу, которая заполняет массив из n элементов целыми четными числами. гарантируется, что 0 < n ≤ 10000 . формат ввода входная строка содержит 2 числа n - количество элементов, а - начальное значение формат вывода программа должна вывести n элементов построенного массива, начиная с a, если а - четное и с а + 1, если а - нечетное, разделенных пробелами пример 1 ввод 5 4 вывод 4 6 8 10 12 пример 2 ввод 5 5 6 8 10 12 14

Показать ответ
Ответ:
Anonim2118
Anonim2118
05.10.2020 20:46
Var
A,N:integer;
M:array[1..10001] of integer;
Begin
ReadLn(N,A);
if A mod 2<>0 then A:=A+1;
For N:= 1 to N do
    Begin
    M[N]:=A;
    A:=A+2;
    Write(M[N],' ')
    End;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота