В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
buster43
buster43
22.05.2021 22:22 •  Информатика

Написать программу нахождения максимального числа, где должны быть: 1. ввод 10 чисел с клавиатуры 2. их перебор с нахождением максимального элемента 3. вывод значения максимального элемента в текстовый файл (программа должна его создать)

Показать ответ
Ответ:
vasnecovadaha
vasnecovadaha
06.10.2020 11:12
Const
   N = 10;
Var
   A:array[1..N] of integer;
   i,Max:integer;
   f:text;
Begin
For i:= 1 to N do
    Read(A[i]);
Max:=A[1];
For i:= 2 to N do
    if A[i] > Max then Max:=A[i];
Assign(f,'Max.txt');
Rewrite(f);
Write(f,Max);
Close(f);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота