20.2 напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 4, или сообщает, что таких чисел нет (выводит no). программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). количество чисел не превышает 100. введённые числа не превышают 300. программа должна вывести среднее арифметическое чисел, кратных 4, или вывести «no», если таких чисел нет. заранее .
begin
repeat
if(y = 100) then break;
readln(x);
if(abs(x) > 300) then begin
writeln('Число по модулю не может быть > 300.');
continue
end
else
if(x mod 4 = 0) and (x <> 0) then begin
inc(count);
s := s + x;
end;if(x <> 0) then inc(y);
until(x = 0);
writeln('Среднее арифметическое: ', s / count);
end.