В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
умник200610
умник200610
02.10.2022 00:33 •  Информатика

2) Дано натуральное число. Напишите программу в phyton, которая находит сумму его цифр.

Показать ответ
Ответ:
Foxer20024
Foxer20024
12.02.2022 19:37

Перш ніж досягти сучасного рівня, обчислювальна техніка пройшла тривалий шлях розвитку. Загалом усю її історію можна поділити на чотири періоди — домеханічний, механічний, електромеханічний та електронний.

Найдавнішим лічильним пристроєм, наданим людині самою природою, була її власна рука. Спочатку люди лічили на пальцях однієї руки, потім на пальцях двох рук, а в деяких племенах використовували для цього ще й пальці ніг.

Наступним кроком у розвитку лічби стало використання камінців та інших предметів. Для запам’ятовування чисел робили зарубки на кістках тварин, в’язали вузлики на мотузках.

Перший у світі автоматичний обчислювальний пристрій для обчислень було описано у 1623 році німецьким ученим Вільгельмом Шиккар-дом. Запропонована ним ідея пристрою із застосуванням підсумкового та розмножувального механізмів використовувалась надалі у всіх механічних обчислювальних машинах.

Першу механічну лічильну машину сконструював у 1645 році французький учений Блез Паскаль. Він виготовив її для полегшення роботи свого батька, що працював податковим інспектором.

Відомий німецький математик Готфрід Вільгельм Лейбніц у 1673 році створив перший арифмометр — машину, яка виконувала чотири арифметичні операції.

У кінці ХІХ ст. американець Герман Голлеріт, син німецьких емігрантів, сконструював електричний перфокартковий обчислювальний пристрій для розв’язування складних статистичних задач. Інформацію кодували за до перфорацій у спеціальних картах, що розміщували в машині у певному порядку. Електричний пристрій розпізнавав отвори і посилав сигнали в обчислювальну машину. Пристрій Голле-ріта був настільки вдалим, що Бюро перепису США використало його

при опрацюванні даних перепису населення у 1880 році. У 1887 році Росія купила цю машину для опрацювання даних першого перепису населення. Пізніше Голлеріт очолив фірму з виробництва перфокарт,

яка з часом перетворилася на відому фірму ІВМ.

Объяснение:

0,0(0 оценок)
Ответ:
poloch
poloch
04.03.2022 03:13

Не очень уверен в правильности данного решения, потестил немного на разных вариантах - вроде работает. Но ощущение, что какой-то он корявый...

n = int(input('Введите количество учеников: '))

a = [list(map(int, input(f'Введите 1<=Xi и Yi<=100 через пробел для {i+1}-го ученика: ').split())) for i in range(n)]

print(a)

i = 0

summ = 0

while i <= len(a)-1:

   if i < len(a)-2:

       if a[i][1] < a[i+1][1]:

           summ += a[i][1]

           i += 2

       else:

           summ += a[i][0]

           i += 1

   elif i == len(a)-2:

       summ += a[i][1]

       i += 2

   else:

       summ += a[i][0]

       i += 1

print(summ)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота