В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Horse3333
Horse3333
04.01.2020 13:32 •  Информатика

10. Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит «NO»). Программа должна вывести среднее арифметическое чисел, кратных 8, или вывести «NO», если таких чисел нет
на языке программирования питон

Показать ответ
Ответ:
mxnty
mxnty
02.03.2021 15:13

mass = [int(s) for s in input().split()]

k = 0

a = 0

for i in range(len(mass)):

   if mass[i] % 8 == 0:

       a += mass[i]

       k += 1

if k == 0:

   print('NO')

else:

   print(a / k)

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота