В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Artur2021
Artur2021
13.10.2020 23:50 •  Информатика

1.заменить все положительные элементы массива на 99. 2.составить программу, вычисл. произведения положительных и сумму отрицательных элементов.

Показать ответ
Ответ:
retul
retul
01.10.2020 10:37
Pascal:
1)
const n = 10;
var a:array [1..n] of integer;
     i:integer;
begin
  randomize;
  for i:=1 to n do
   begin
    a[i]:=random(21)-10;
    write (a[i]:3);
   end;
  writeln;
  for i:=1 to n do
   begin
    if a[i]>0 then a[i]:=99;
    write (a[i]:3);
   end;
  writeln;
end.

2)
const n = 10;
var a:array [1..n] of integer;
     p,s,i:longint;
begin
  p:=1;
  s:=0;
  randomize;
  for i:=1 to n do
   begin
    a[i]:=random(21)-10;
    if a[i]>0 then p:=p*a[i] else
     if a[i]<0 then s:=s+a[i];
    write(a[i]:3);
   end;
  writeln;
  writeln ('Proizvedenie: ',p);
  writeln ('Summa: ',s);
end.

C++:
1)
#include <iostream>
#include <ctime>
#include <cstdlib>
using namespace std;

int main()
{
  int a[10];
  srand (time(NULL));
  for (int i = 0; i<10; i++)
  {
    a[i] = rand()%20-10;
    cout <<a[i] <<" ";
    if (a[i]>0)
      a[i] = 99;
  }
  cout <<endl;
  for (int i = 0; i<10; i++)
    cout <<a[i] <<" ";
  cout <<endl;
  return 0;
}

2)
#include <iostream>
#include <ctime>
#include <cstdlib>
using namespace std;

int main()
{
  int a[10];
  int p = 1,s = 0;
  srand (time(NULL));
  for (int i = 0; i<10; i++)
  {
    a[i] = rand()%20-10;
    cout <<a[i] <<" ";
    if (a[i]>0)
      p*=a[i];
    else if (a[i]<0) s+=a[i];
  }
  cout <<endl;
  cout <<"Summa: " <<s <<endl
         <<"Proizvedenie: " <<p <<endl;
  return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота