В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
AlinaRai
AlinaRai
18.03.2022 12:05 •  Информатика

1. Дан массив А(N). Найти сумму элементов массива, кратных 8 и произведение положительных элементов. 2. Дана матрица В(N;N). Найти максимальный элемент, расположенный на главной диагонали и его индексы по столбцу и строке.
1. Дан массив А(N). Найти произведение элементов массива, меньших числа К и сумму элементов кратных 3. 2. Дана матрица В(N;N). Найти кол-во элементов, кратных 5, находящихся ниже главной диагонали.
1. Дан массив А(N). Найти кол-во элементов массива, равных В. и произведение отрицательных элементов. 2. Дана матрица В(N;N). Найти произведение отрицательных элементов, находящихся выше побочной диагонали.
1. Дан массив А(N). Найти произведение отрицательных элементов, кратных 3, имеющих четные индексы и их кол-во. 2. Дана матрица В(N;N). Найти сумму положительных элементов, находящихся выше главной диагонали.
1. Дан массив А(N). Найти кол-во элементов массива, равных нулю и сумму отрицательных элементов. 2. Дана матрица В(N;N). Найти произведение отрицательных элементов, находящихся выше побочной диагонали.
РЕШИТЬ БЛОК-СХЕМОЙ

Показать ответ
Ответ:
nasik134
nasik134
11.03.2021 02:45
F = ¬X +Z⇒(X+¬Y)
таблица истинности:
X Y Z     X+¬Y   Z⇒(X+¬Y)    ¬X      F
0  0  0      1             1                1       1
0  0  1       1            1                1       1
0  1  0       0            1                1       1
0  1  1       0            0                1       1
1  0  0      1             1                0       1
1  0  1       1            1                0       1
1 1   0       1            1                0       1
1  1  1      1             1                0       1
F =1 тождественно истинна ,
 так как её значения равны 1 при любых X,Y,Z
0,0(0 оценок)
Ответ:
LizaZZ6
LizaZZ6
28.11.2022 17:10
Const n=10; 
type ar=array[1..n+1] of integer;
var 
a:ar; i,p:integer; 
procedure pr(var a:ar; p:integer; var k:integer);
begin
k:=1;
while a[k]<>p do k:=k+1;
end;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(31);
 write(a[i]:4);
 end;
writeln;
p:=17;
a[n+1]:=p;
pr(a,p,i);
if i<n 
 then writeln('Значение 17 найдено, номер элемента = ',i)
 else writeln('Значения 17 в массиве нет');
end.

Пример:
Массив A:
  14   5   7  17  25  15  28   0  24   0
Значение 17 найдено, номер элемента = 4
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота