В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
дизззи
дизззи
18.04.2023 22:31 •  Информатика

1.составьте программу вычисления суммы цифр двузначного числа 2. составьте программу вычисления суммы цифр трёхзначного числа

Показать ответ
Ответ:
Данила4688
Данила4688
29.07.2020 07:10
Program znanija;
var a,s:integer;
begin
Read(a);
while a<>0 do 
begin   
s:= s + a mod 10;   
a:= a div 10 
end;
writeln(s);
end.

Работает для многозначных цифр не превышающих integer 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота