В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
deryabina92
deryabina92
03.01.2023 10:08 •  Информатика

1. составьте программу, которая запрашивает с клавиатуры значения x и y. если x> y то печатается разность x-y, в противном случае y-x. 2. напишите программу, которая запрашивает с клавиатуры a, b, c. если a> b+c, то на печать выводится a. в другом случае выводится b+c. 3. напишите программу, которая запрашивает с клавиатуры значения k и x. если k=1, то вычисляется значение sin(x), если k=2, то вычисляется значение cos(x). 4. напишите программу, которая запрашивает значения p и m. если p> m2 , то печатается p, в противном случае m2. сделайте в паскале) и можете меня научить ?

Показать ответ
Ответ:
Loler57ùö
Loler57ùö
07.10.2020 08:33
//Pascal
//1)
var x, y: integer;
begin
write('Введите x y: ');
read(x, y);
if x > y then
writeln(x - y)
else
 writeln(y - x);
end.

//2)
var a, b, c: integer;
begin
write('Введите a b c: ');
read(a, b, c);
if (a > (b + c)) then
writeln(a)
else
writeln(b + c);
end.

//3)
var x, k: integer;
begin
write('Введите x k: ');
read(x, k);
if k = 1 then
writeln(sin(x))
else
if k = 2 then
writeln(cos(x))
else
writeln('k должен быть равен 1 или 2.');
end.

//4)
var p, m: integer;
begin
  write('Введите p, m: ');
  read(p, m);
  if p > m * 2 then
    writeln(p)
  else
    writeln(m * 2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота