В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
мария21112006
мария21112006
07.08.2021 13:46 •  Информатика

1.составить программу в паскале,которая предлагает ивану -царевичу выбрать правильное направление пути.у ивана-царевича есть три варианта дальнейшего пути: направо,-"коня потеряешь" налево,-"голову сложишь" вперёд,-"невесту найдёшь" 2.составить прогрмму,которая определяет положительное число или отрицательное. 3.дано целое число а.если значение а> 0,то необходимо его уыеличить на единицу.если в< 0,то уменьшить на единицу. зарание : )

Показать ответ
Ответ:
милана05051
милана05051
11.06.2020 08:20

program cvdcnio

uses crt;

var a:string;

begin

clrscr;

case a of

'Направо':writeln('Коняш');

'Налево': writeln('Голова');

'Вперед': writeln('Невестка');

readln

end.

 

program fcndkjn;

uses crt;

var a:integer;

begin

clrscr;

readln(a);

if a>0 then writeln(+) else writeln(-);

readln;

end.

 

program fmc;

uses crt;

var a:integer;

begin

clrscr;

readln(a);

if a>0 then writeln(a+1) else writeln(a-1);

readln;

end.  Надеюсь тут в условии, не b<0, а a<0

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота