В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
FzdAngels
FzdAngels
13.12.2022 22:48 •  Информатика

Напишите программу, после первого четного элемента вставить 0. пример: из массива a[5]: 1 6 8 3 4 должен получиться массив a[6]: 1 6 0 8 3 4.

Показать ответ
Ответ:
Winxsori
Winxsori
21.07.2020 07:28
Const     
n = 10; 
var   
a : array [1..n] of integer; 
r : boolean;   
i,j : integer;
 begin 
//Формирование массива пропущено   
 
r := true;      
While r do   
begin   
 if a[i] mod 2 =0 then     
begin     
 for j := n-1 downto i + 2 do       
 a[j] := a[j-1];       
a[i+1] := 0;       
r := false;     
end;     
i := i +1;   
end;  
for i := 1 to n do 
writeln (a[i]);   
end.

Во избежании ошибок стоит учесть наличие такового элемента в массиве и размерность массива (чтобы его можно было корректно расширить на один элемент)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота