№1 составить программу: с цикла for пощитать сумму всех трехзначных чисел кратных 4. №2 составить программу: с цикла whiie пошитать сумму чисел кратных 5 из диапозона от 500 до 1000
Первая программа: program qwer; uses crt; var sum,i:integer; Begin sum := 0; for i := 100 to 999 do if i mod 4 = 0 then sum := sum + i; write(sum); End. Вторая программа: program qwer; uses crt; var sum, i : integer; Begin sum := 0; i := 500; sum := 0; while i <1001 do begin if i mod 5 = 0 then sum := sum + i; i := i + 1; end; write(sum); End.
program qwer;
uses crt;
var sum,i:integer;
Begin
sum := 0;
for i := 100 to 999 do
if i mod 4 = 0 then sum := sum + i;
write(sum);
End.
Вторая программа:
program qwer;
uses crt;
var sum, i : integer;
Begin
sum := 0;
i := 500;
sum := 0;
while i <1001 do
begin
if i mod 5 = 0 then sum := sum + i;
i := i + 1;
end;
write(sum);
End.