В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
HelpmeAnna1
HelpmeAnna1
24.09.2021 14:16 •  Информатика

Составить программу вычисления суммы цифр введенного с клавиатуры 3- х значного натурального числа . например для числа 128 сумма цифр 11, а для числа 345 сумма цифр12.

Показать ответ
Ответ:
svelt04
svelt04
02.10.2020 02:37
Program gt;
var n,s:integer;
begin
readln(n);
s:=(n div 100)+(n div 10)mod 10+(n mod 10);
writeln(s);
end.
каждая скобка это 1 2 3 цифра соответсвенно
0,0(0 оценок)
Ответ:
семенггвп
семенггвп
02.10.2020 02:37
Var a,N,sum:word;
begin
Read (N);
Sum:=0;
While N<>0 do
begin
a:=N mod 10;
N:=N div 10;
Sum:=sum+a;
end;
Write (sum);
end.

Или по-простому еще так:
Var a,b,c,N:word;
begin
Read (N);
a:=N mod 10;
b:=(N mod 100) div 10;
c:=N div 100;
Write (a+b+c);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота