Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Mimosa1233
22.02.2023 02:57 •
Информатика
1. Составить программу алгоритма ветвления вычисления выражения: 2. (*). Даны 2 числа a,b. Наименьшее уменьшить вдвое.
Показать ответ
Ответ:
evgenijpetrov
08.03.2023 07:22
Vara,b,c,d,x1,x2: real;
begin
writeln('Дано уравнение вида ax^2+bx+c=0');
Writeln ('Укажи переменную "a"');
readln(a);
Writeln ('Укажи переменную "b"');
readln(b);
Writeln ('Укажи переменную "c"');
readln(c);
if a = 0
then writeln('Не квадратное уравнение!')
else begin
d:= sqr(b)-4*a*c;
if d < 0 then writeln('Нет корней')
else begin
x1:= (-b+sqrt(d))/2*a;
x2:= (-b-sqrt(d))/2*a;
writeln ('X1 =',x1,' X2 =',x2);
end;
end;
end.
0,0
(0 оценок)
Ответ:
Tata123N
15.09.2022 17:56
Если считать отрицательные трехзначные, то сумма таких чисел в диапазонах от -999 до -100 и от 100 до 999 будет равна 0. Для только положительных:
//c циклом for
var s,i:integer;
begin
for i:=100 to 999 do
if i mod 77 = 0 then s:=s+i;
writeln('Сумма трехзначных кратных 77: ',s);
end.
Тестовое решение:
Сумма трехзначных кратных 77: 5929
// с циклом while
var s,i:integer;
begin
i:=100;
while i<=999 do begin
if i mod 77 = 0 then s:=s+i;
i:=i+1;
end;
writeln('Сумма трехзначных кратных 77: ',s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
марина7811
08.04.2022 06:10
Нарисовать в pascalabc движущийся круг с левой стороны на правую...
элизабет35
08.04.2022 06:10
Сколько битов памяти достаточно для кодирования одного пикселя 64 цветного изображения...
Cheloces
31.08.2020 02:48
Написать загадки на тему безопасный интернет 10 загадок...
OTJTu4HuK
25.10.2021 07:13
Нужна программа на c#: даны действительные числа x и y. определить, принадлежит ли точка скоординатами x, y заштрихованной области, лежит вне ее или на ее границе....
Женечка180510
12.01.2023 19:29
Решить в паскале: вывести последовательность чисел 11,22,33,...
ilka2004z
12.01.2023 19:29
Program gg; var a,b,c,d,e,max: integer; begin writeln( введите пять целых чисел ); read(a,b,c,d,e); if (a =b) and (a =c) and (a =d) and (a =e) then begin max: =a;...
myrzik5293p081ps
12.01.2023 19:29
1. примером непозиционной системы счисления является римская система (римские цифры). в римской системе в качестве цифр используются латинские буквы: в римских числах...
5Ник4
12.08.2020 08:15
Составить программу которая создаёт массив случайных чисел в диапазоне (-10,10) . найти сумму положительных и сумму отрицательных элементов массива...
Анкта
27.12.2021 03:56
какой минимальный объём памяти (в кбайт) нужно зарезервировать, чтобы можно было сохранить любое растровое изображение размером 128×128 пикселей при условии,...
БлэккКээт
13.11.2021 14:07
Решите с паскаля,. найдите расстояние,которое проедет авто за заданный период времени(t),если его начальная скорость (v0) и ускорение (а)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
writeln('Дано уравнение вида ax^2+bx+c=0');
Writeln ('Укажи переменную "a"');
readln(a);
Writeln ('Укажи переменную "b"');
readln(b);
Writeln ('Укажи переменную "c"');
readln(c);
if a = 0
then writeln('Не квадратное уравнение!')
else begin
d:= sqr(b)-4*a*c;
if d < 0 then writeln('Нет корней')
else begin
x1:= (-b+sqrt(d))/2*a;
x2:= (-b-sqrt(d))/2*a;
writeln ('X1 =',x1,' X2 =',x2);
end;
end;
end.
//c циклом for
var s,i:integer;
begin
for i:=100 to 999 do
if i mod 77 = 0 then s:=s+i;
writeln('Сумма трехзначных кратных 77: ',s);
end.
Тестовое решение:
Сумма трехзначных кратных 77: 5929
// с циклом while
var s,i:integer;
begin
i:=100;
while i<=999 do begin
if i mod 77 = 0 then s:=s+i;
i:=i+1;
end;
writeln('Сумма трехзначных кратных 77: ',s);
end.