В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
5Ник4
5Ник4
12.08.2020 08:15 •  Информатика

Составить программу которая создаёт массив случайных чисел в диапазоне (-10,10) . найти сумму положительных и сумму отрицательных элементов массива

Показать ответ
Ответ:
СоняЗагребова5
СоняЗагребова5
07.10.2020 20:25
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
var a:=ArrRandom(10,-10,10);a.Println;
var (sum1,sum2):= (a.Where(t -> t > 0).Sum,a.Where(t -> t < 0).Sum);
Writeln(sum1, ' ', sum2);
end.

Пример:
5 -2 -3 6 -7 -8 -7 7 -1 4
22 -28
0,0(0 оценок)
Ответ:
temnikovay01
temnikovay01
07.10.2020 20:25
Const
  nn=100;

var
  i,n,sn,sp:integer;
  a:array[1..nn] of integer;

begin
  Write('n = '); Read(n);
  Randomize;
  sn:=0; sp:=0;
  for i:=1 to n do begin
    a[i]:=Random(21)-10;
    Write(a[i],' ');
    if a[i]>0 then sp:=sp+a[i]
    else
      if a[i]<0 then sn:=sn+a[i]
    end;
  Writeln;
  Writeln('Сумма отрицательных ',sn,', сумма положительных ',sp)
end.

Пример
n = 13
8 4 10 6 -2 2 -9 -9 6 3 2 4 -7
Сумма отрицательных -27, сумма положительных 45
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота