В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
qamqsmbfhfuc
qamqsmbfhfuc
04.04.2020 14:35 •  Информатика

1.напишите программу вычисления значений переменной а.если a=2x+18y2.напишите программу вычисления длины гипотенузы прямоугольного треугольника​

Показать ответ
Ответ:
вовчик83
вовчик83
10.06.2020 12:20

С++ :

1)

#include <iostream>

using namespace std;

int x,y,a;

int main()

{

cout << "Enter X and Y " << endl;

cin >> x >> y;

a=2*x + 18*y;

cout << "a = " << a;

}

2)

#include <iostream>

#include <cmath>

using namespace std;

float a,b,c;

int main()

{

cout << "Enter A and B " << endl;

cin >> a >> b;

c=sqrt(pow(a , 2) + pow(b , 2));

cout << "c = " << c;

}

Комментарий :

a,b - катеты, c - гипотенуза.pow(a,b) - возведение числа a в степень b ( аналогом может служить умножения переменной самой на себя)

2)

Pascal :

program ideone;

uses crt;

var a,b,c:real;

begin

 clrscr;

 write('Введите А и В');

 readln(a,b);

 c:=sqrt(a*a + b*b);

 writeln(c);

end.

1)

program ideone;

uses crt;

var a,x,y:integer;

begin

 clrscr;

 write('Введите X и Y ');

 readln(x,y);

 a:=2*x + 18*y;

 writeln(a);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота