В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
5656200
5656200
01.12.2021 07:07 •  Информатика

1. Напишите программу, которая запрашивает целое число, и если оно положительное -- пишет "YES", в противном случае - "NO". Пример 1: 5
Вывод 1: YES
Пример 2: -4
Вывод 2: NO

2. Напишите программу, которая запрашивает целое число, и если оно меньше или равно 1000 - пишет "YES", в противном случае - "NO".
Пример 1: 500
Вывод 1: YES
Пример 2: 1001
Вывод 2: NO

3. Напишите программу, которая запрашивает натуральное число, и если оно оканчивается на 9 - пишет "YES", в противном случае - "NO".
Пример 1: 239
Вывод 1: YES
Пример 2: 98
Вывод 2: NO

Показать ответ
Ответ:

вот возможный вариант, если числа номер вводится с клавиатуры:

#include <iostream>

#include <clocale>

using namespace std;

int main()

{

setlocale(LC_ALL, "Russian");

int a, b, c, d, e, f;

int x = 0;

cout << "Введите номер билета: ";

cin >> a >> b >> c >> d >> e >> f;

x = a + b + c;

if ( x == d + e + f)

 cout << "Номер вашего билета: " << a << b << c << d << e << f << ". " << "Ваш билет счастливый!";

else cout << "Номер вашего билета: " << a << b << c << d << e << f << ". " << "Увы, ваш билет не счастливый.";

}

0,0(0 оценок)
Ответ:
SmokeSivunenko
SmokeSivunenko
16.02.2022 08:04

Фрагмент программы будет выполнятся вечно, значение переменной c получить нельзя.

Объяснение:

Присваиваем переменной a число 100:

a:=100;

Присваиваем переменной b число 20:

b:=20;

Далее идёт цикл с постусловием, выполняем тело, пока b не станет больше или равна 100:

repeat

i:= a div b;

c:=i + 5;

b:= a div b;

until b>=100;

Смотрим:

i  =  a div b  =   100 div 20  =  5c =  i + 5  =  5 + 5  =  10 b =  a div b   =   100 div 20  =  5

b>=100 ? нет  =>  ещё раз:

i  =  a div b  =   100 div 5  =  20c =  i + 5  =  20 + 5  =  25b =  a div b   =   100 div 5  =  20

Переменная b изначально была равна 20, а через 2 прохода цикла, она также стала 20. Делаем вывод: это замкнутый цикл, выполнятся он будет вечно, так как переменная b никогда не будет >=100.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота