В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Лелечка43
Лелечка43
08.07.2021 02:29 •  Информатика

§ 18. Линейные программы 1. Требуется написать программу, которая складывает два числа и выводит на экран их сумму. Определите входные данные и результат этого алгоритма.

К какому типу относятся входные данные:

Сколько входных значений у алгоритма?

К какому типу относятся результаты:

Сколько результатов у алгоритма?

Обозначьте именами входные данные и результаты и напишите их на стрелках:

Запишите формулу, которая связывает исходные данные и результат:

Место для ввода текста.

2. Требуется написать программу, которая выводит скорость и время движения автомобиля и выводит на экран расстояние, которое он проехал. Определите входные данные и результат этого алгоритма.

К какому типу относятся входные данные:

Сколько входных значений у алгоритма?

К какому типу относятся результаты:

Сколько результатов у алгоритма?

Обозначьте именами входные данные и результаты и напишите их на стрелках:

Запишите формулу, которая связывает исходные данные и результат:

Место для ввода текста.

3. В языке Python целые переменные относятся к типу (классу) int. Выясните, откуда произошло сокращение int в языках программирования:

int – это сокращение от английского слова , которое переводится как .

4. Выделите красным цветом недопустимые имена переменных:

1 Vasya СУ-27 @mail_ru

m11 Петя СУ_27 lenta.ru

1m Митин брат _27 "Pes barbos"

m 1 Quo vadis СУ(27) <Ладья>

5. Что появится на экране после выполнения программы:

c = 5

print( с )

print( 'c' )

ответ:

Чем отличаются два оператора вывода в программе?

Место для ввода текста.

6. Что выведет на экран программма

a = 1

print( a )

a = 5

print( a ) ответ:

Заполните пропуски: «Если переменной присваивается новое значение, то предыдущее значение .»

Выберите правильный вариант: «Переменная в любой момент может иметь ».

7. Чему будут равны значения переменных a и b после выполнения программмы, если вначале они имели значения a = 4 и b = 7? Выполните ручную прокрутку программы.

a b

4 7

a = a + 1

b = b + 1

a = a + b

b = b + a

a = a + 1

ответ: a = b =

8. Что выведет эта программа при a = 4, b = 5 и c = 9?

print( 'a', '+b', =, c )

Место для ввода текста.

9. Исправьте ошибки в операторе вывода,

print( 'c', '-b', =, a )

чтобы при a = 4, b = 5 и c = 9 программа вывела 9–5=4:

Место для ввода текста.

10. Определите порядок действий компьютера при вычислении выражения (впишите номер выполняемого действия над знаком операции):

11. Запишите присваивание на языке программирования:

Место для ввода текста.

12. Как можно записать возведение в квадрат, куб, 10-ю степень на языке Python?

с  x2 d  (x+2)3

d  12+z10

Показать ответ
Ответ:
ENOT234u
ENOT234u
04.07.2022 10:07

"...напечатает сначала 2, потом - 6" -- это значит a=2 и b=6?


про пятеричные записи ничего не понял...  :) И ИМХО к чему такие сложности? И для чего нам комп и программа? Я подправил исходную прогу чтобы она выдавала все числа подходящие по условию

var x,a,b: longint;


begin

   for var i := 999 DownTo 100 do begin

       a := 0;

       b := 1;

       x := i;

       while x>0 do begin

           if x mod 2 > 0 then a := a+1 else b := b+(x mod 5);

           x := x div 5;

       end;

       if (a = 2) and (b = 6) then writeln('x = ', i, ' a = ', a, ' b = ',b);

   end;

end.


прога проводит расчет для всх трехзначных чисел от 999 до 100

итого мы видим что максимальное подходящее число это 960

при необходимости прогу можно переделать чтобы она находила только максимальное число.

0,0(0 оценок)
Ответ:
сичоврчс
сичоврчс
25.07.2021 13:50

розгалуження виконується, коли виконання попереднього розгалуження ще не закінчено.

Наприклад, вам потрібно встановити будильник на завтра. Якщо

завтра робочий день, то ви повинні встати о 7-й годині ранку, щоб іти

до школи. Якщо завтра субота, то ви повинні встати о 8-й годині ранку, щоб їхати на заняття гуртка. Якщо завтра неділя, то ви встаєте о

9-й годині ранку.

У наведеному на малюнку алгоритмі друге розгалуження з

умовою Завтра субота? міститься всередині першого розгалуження з

умовою Завтра робочий день?.

Такий фрагмент алгоритму називають вкладеним розгалуженням.

Вкладені розгалуження - це фрагмент алгоритму, у якому одне

розгалуження міститься всередині іншого розгалуження.

Розглянемо виконання наведеного на малюнку 3.26 фрагмента алгоритму. Спочатку перевіряється умова Завтра робочий день?. Якщо

результат перевірки цієї умови Так, то виконується команда Установити будильник на 7-му годину ранку і на цьому виконання всього

цього фрагмента алгоритму закінчується. Якщо результат перевірки

умови Завтра робочий день? - Ні, то перевіряється умова Завтра субота?. Якщо результат перевірки цієї умови Так, то виконується команда

Установити будильник на 8-му годину ранку і на цьому виконання всього цього фрагмента алгоритму закінчується, а якщо результат перевірки

цієї умови Ні, то виконується команда Установити будильник на 9-ту

годину ранку і виконання всього цього фрагмента алгоритму закінчується.

У наведеному на малюнку

фрагменті алгоритму внутрішнє

розгалуження виконується, якщо результат перевірки умови зовнішнього розгалуження Ні.

Объяснение:

рисунок 3.26 (во вложении)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота