В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Арнур1234
Арнур1234
15.10.2022 18:55 •  Информатика

1.написать программу, которая вычисляет частное двух чисел. программа должна проверять правильность введенных пользователем данных и, если они неверные (делитель равен нулю), вы давать сообщение об ошибке. ниже рекомендуемый вид экрана во время выполнения программы (данные, введенные пользователем, выделены полужирным шрифтом). вычисление частного. введите в одной строке делимое и делитель, затем нажмите . -> 12 о вы ошиблись. делитель не должен быть равен нулю.

Показать ответ
Ответ:
viktoria388
viktoria388
02.07.2020 01:23
Program qq;
Var a, b, c:real;
Begin
Writeln('введите два числа');
Readln(a,b);
If b=0 then begin writeln('делитель не должен равняться нулю, введите числа повторно')
readln(a, b);
End
If else begin c:=a/b;
End
Writeln('получившееся число', c)
End.
Может где-нибудь есть косячок, но в основном, все должно получиться, удачи:)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота