В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ataev0512
ataev0512
22.11.2020 20:52 •  Информатика

1.написать программу для вычисления двойного факториала. 2) ввести натуральное n и вычислить сумму 1+1/2+1/3+1/4++1/n-1+1/n

Показать ответ
Ответ:
nakjuo
nakjuo
26.08.2020 11:53
Var
   F2:real;
   n,F:longint;
Begin
Write('n = ');ReadLn(n);
F:=1;
For n:= 1 to n do
    F:=F*n;
F2:=1;
For n:= 1 to F do
    F2:=F2*n;
WriteLn('n = 6.68950291344912E+198

Больше не выдержит вещественный тип.

Var
   S:real;
   N:integer;
Begin
Write('N = ');
ReadLn(N);
S:=0;
For N:= 1 to N do
    S:=S+1/N;
WriteLn('S = ',S);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота