В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
daniilkrkrahmal
daniilkrkrahmal
30.03.2023 10:20 •  Информатика

№1. дана последовательность целых чисел. напишите программу, подсчитывающую, сколько в этой последовательности отрицательных чисел. №2. дана последовательность целых чисел. напишите программу, вычисляющую сумму положительных чисел.

Показать ответ
Ответ:
artem20051105
artem20051105
10.06.2020 02:04
№1                                        

program raf105;

var a,otr: integer;

begin

writeln('Вводите числа по очереди');

writeln('Чтобы закончить введите 0');

repeat

 readln(a);

 if a<0

   then otr+= 1;

until a = 0;

writeln('Отрицательных чисел: ',otr);

end.

№2                                        

program raf105;

var a,sum: integer;

begin

writeln('Вводите числа по очереди');

writeln('Чтобы закончить введите 0');

repeat

 readln(a);

 if a>0

   then sum+= a;

until a = 0;

writeln('Сумма положительных чисел: ',sum);

end.

                                              PascalABC 3.4.2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота