Информатика 9 класс 3. составить программу планирования закупки товара в магазине на сумму, не превышающую заданную величину. обозначим через x,k-соответствующую цену и количество товара, а через p-заданную предельную сумму, через s- общую стоимость покупки. значение предельной суммы считывается с клавиатуры. необходимо повторять запрос цены и количества выбранного товара, вычислять его стоимость, суммировать ее с общей стоимостью и выводить результат на экран до тех пор, пока она не превысит предельную сумму p.
program Goods;
var x,k,p,s: word;
begin
writeln('Введите предельную сумму:');
readln(p);
s:=0;
while s<=p do
begin
writeln('Введите стоимость вещи:');
readln(x);
writeln('Введите количество:');
readln(k);
s:=s+x*k;
writeln('Сумма затрат:', s);
writeln('Предел суммы:', p)
end;
writeln('Вы превысили сумму покупок')
end.