Здраствуйте Все задачи делать в системе Python!
Не делать тяп ляп!
Можно приложить скриншоты из Python.
Задачи:
1. Ввести три целых числа, найти наибольшее и наименьшее из них.
2. Напишите программу, которая получает три числа - рост трёх спортсменов, и выводит сообщение «По росту.», если они стоят по возрастанию роста, или сообщение «Не по росту!», если они стоят не по росту.
3. Напишите программу, которая получает номер месяца и выводит соответствующее ему время года или сообщение об ошибке.
4. Заданы x1, y1, x2, y2 (x1, y1, x2, y2 ≠0). Лежат ли точки (x1, y1) и (x2, y2): в одной четверти?
5. Напишите программу печати таблицы перевода расстояний из дюймов в сантиметры для значений длин от 1 до 20 дюймов. 1 дюйм = 2,54 см.
6. В бригаде, работающей на уборке сена, имеется N косилок. Первая из них работала M часов, а каждая следующая на 10 минут больше, чем предыдущая. Сколько часов проработала вся бригада?
7. Гражданин 1 марта открыл счет в банке, вложив 1000 руб. Через каждый месяц размер вклада увеличивается на 2% от имеющейся суммы. Определить: сумму вклада через три, четыре, ..., двенадцать месяцев.
8. Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего дня. Определить: пробег лыжника за второй, третий, ..., десятый день тренировок;
9. Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего дня. Определить: какой суммарный путь он пробежал за первые 7 дней тренировок.
10. В некотором году (назовем его условно первым) на участке в 100 гектаров средняя урожайность ячменя составила 20 центнеров с гектара. После этого каждый год площадь участка увеличивалась на 5%, а средняя урожайность на 2%. Определить: урожайность за второй, третий, ..., восьмой год;
11. В некотором году (назовем его условно первым) на участке в 100 гектаров средняя урожайность ячменя составила 20 центнеров с гектара. После этого каждый год площадь участка увеличивалась на 5%, а средняя урожайность на 2%. Определить: площадь участка в четвертый, пятый, ..., седьмой год;
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),2,5); a.Println;
var b:=a.GroupBy(t->t).Select(t->(t.Key,t.Count)).OrderBy(t->t[0])
.Select(t->t[1]).ToArray;
Writeln('Сдано на 5: ',b[3]);
Writeln('Сдано на 4: ',b[2]);
Writeln('Сдано на 3: ',b[1]);
Writeln('Не допущено: ',b[0])
end.
Пример
n= 20
4 4 3 5 4 5 2 4 4 4 5 4 3 3 4 2 3 2 2 2
Сдано на 5: 3
Сдано на 4: 8
Сдано на 3: 4
Не допущено: 5