Заполните одномерный числовой массив С(10) случайными целыми числами в интервале [-15; 15]. Задача 9.0. Выведите значения элементов массива сначала в столбик, а затем в строку, причём, на каждый элемент отведите 4 позиции, сделайте один запуск. В задачах 9.1, 9.2 и 9.3 вывод массива осуществляется в строку, на каждый элемент массива отводится 4 позиции. ответ каждой задачи следует выводить с новой строки и с пояснительным текстом. Кроме того, следует каждый раз производить вывод массива на экран, если в нём произошли изменения: перестановка, замена, изменение значения элементов и т.д.
Задача 9.1.
Найдите произведение элементов массива с нечётными номерами.
Задача 9.2.
Найдите максимальный по модулю элемент массива.
Задача 9.3.
Выведите на экран одномерный массив, раскрасив в нём синим цветом первый кратный 5 элемент.
var
i, a, b, n, n2, j: longint;
s: string;
flag: boolean;
begin
Write('Введите через пробел границы диапазона: ');
Readln(a, b);
if b < a then begin n := a; a := b; b := n end;
if a < 11 then a := 11;
for i := a to b do
begin
Str(i, s);
n := Length(s); n2 := n div 2; flag := true; j := 1;
repeat
flag := (s[j] = s[n - j + 1]);
j := j + 1
until (not flag) or (j > n2);
if flag then Write(i, ' ')
end;
end.
Тестовое решение:
Введите через пробел границы диапазона: 800 1500
808 818 828 838 848 858 868 878 888 898 909 919 929 939 949 959 969 979 989 999
Объяснение: