В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
DANIKom
DANIKom
30.05.2022 12:09 •  Информатика

Заполните массив А из 100 элементов последовательно идущими целыми числами от 1 до 100. Напишите программу, которая вычислит в этом массиве количество элементов кратных двум, трем и четырем одновременно

Показать ответ
Ответ:
eio32120kopqicom
eio32120kopqicom
26.04.2021 20:00

var

A: array [1..100] of integer;

i, div2, div3, div4: integer;

begin

for i:=1 to 100 do

begin

A[i]:=i;

if A[i] mod 2=0 then

div2:=div2+1;

if A[i] mod 3=0 then

div3:=div3+1;

if A[i] mod 4=0 then

div4:=div4+1;

end;

writeln('Кол-во чисел от 1 до 100');

writeln('кратных 2: ', div2);

writeln('кратных 3: ', div3);

writeln('кратных 4: ', div4);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота