Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
куангы8789уш
18.02.2021 15:15 •
Информатика
Запишите полный текст программы на Pascal (линейный алгоритм):
Программа запрашивает количество и цену 3-х покупок (целые числа). Вычисляется и выводится общая стоимость всех покупок.
Показать ответ
Ответ:
Ram543
13.12.2020 06:29
While (tnum != 0) //tnum, tden - числитель и знаменатель искомой дроби
{
if (tnum < tden)
{
temp = tnum;
tnum = tden;
tden = temp;
}
tnum = tnum - tden;
}
gcd = tden; //вычисляем наибольший общий делитель
numerator = numerator / gcd; //делим числитель и знаменатель на
НОД, получаем сокращенную дробь
denominator = denominator / gcd;
0,0
(0 оценок)
Ответ:
evgenijpetrov
08.03.2023 07:22
Vara,b,c,d,x1,x2: real;
begin
writeln('Дано уравнение вида ax^2+bx+c=0');
Writeln ('Укажи переменную "a"');
readln(a);
Writeln ('Укажи переменную "b"');
readln(b);
Writeln ('Укажи переменную "c"');
readln(c);
if a = 0
then writeln('Не квадратное уравнение!')
else begin
d:= sqr(b)-4*a*c;
if d < 0 then writeln('Нет корней')
else begin
x1:= (-b+sqrt(d))/2*a;
x2:= (-b-sqrt(d))/2*a;
writeln ('X1 =',x1,' X2 =',x2);
end;
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
школоллло
02.10.2022 10:40
Построить таблицу значения функции y=x^2+8x+16 в пределах от -4 до +4 с использованием процедуры....
ayska1
10.02.2020 21:26
Для удобства работы с файлами их группируют 1)в корневые каталоги, 2) в каталоги, 3) в архивы, 4) в карту памяти...
chmv555
22.02.2021 14:40
Запишите содержимое (в шестнадцатеричной системе) регистра bh, полученное в результате выполнения следующих операторов ассемблера: mov bh, 0d7h mov cl, 3 sal bh,...
влажную
06.12.2022 15:20
Составить программу в паскале! известна стоимость 1 кг конфет, печенья, яблок. найти стоимость всей покупки, если купили х кг конфет, y кг печенья и z кг яблок....
8800553535Qwerty
06.07.2020 20:46
Напишите процедуру, которая принимает один параметр – натуральное число n, – и выводит на экран прямоугольник длиной n и высотой 3 символа....
Vadik01K
18.01.2023 16:55
Дополните таблицу поколения процессоров с 1978-2017годы...
nogtev70
07.04.2022 20:43
Как записывается десятичное число 25 10 в двоичной системе счисления? .....
ятебемогупомоч
24.01.2022 10:53
Или объясните как решать эту фигню. эта пожилая мышь дала кт за 25 м до звонка ...
Михона
19.02.2021 17:23
Самостоятельная работа по информатике переведите данные числа из десятичной системы счисления в двоичную систему счисления...
JanoX
03.06.2020 04:33
Дана программа ее надо изменить так чтобы с ее можно было найти разность максимального и минимального из четырех чисел программа program n_7; var a,b,c,d: integer;...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
{
if (tnum < tden)
{
temp = tnum;
tnum = tden;
tden = temp;
}
tnum = tnum - tden;
}
gcd = tden; //вычисляем наибольший общий делитель
numerator = numerator / gcd; //делим числитель и знаменатель на
НОД, получаем сокращенную дробь
denominator = denominator / gcd;
begin
writeln('Дано уравнение вида ax^2+bx+c=0');
Writeln ('Укажи переменную "a"');
readln(a);
Writeln ('Укажи переменную "b"');
readln(b);
Writeln ('Укажи переменную "c"');
readln(c);
if a = 0
then writeln('Не квадратное уравнение!')
else begin
d:= sqr(b)-4*a*c;
if d < 0 then writeln('Нет корней')
else begin
x1:= (-b+sqrt(d))/2*a;
x2:= (-b-sqrt(d))/2*a;
writeln ('X1 =',x1,' X2 =',x2);
end;
end;
end.