В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
MaxymMelehovets
MaxymMelehovets
27.03.2021 10:48 •  Информатика

Записать что дано, найти, составить блок-схему и программу в паскале 1. Даны два числа. Возвести в квадрат те из них, значения которых
неотрицательны, и увеличить на 2,5 те, которые положительны.
2. Подсчитать количество отрицательных среди чисел a, b, c.
3. Рис расфасован в два пакета. Масса первого — Т кг, второго п
кг. Составить программу, определяющую:
а) какой пакет тяжелее — первый или второй;
6) массу более тяжелого пакета. І​

Показать ответ
Ответ:
daniltyrov719
daniltyrov719
15.02.2023 13:58
//Вот программа, которая кодирует слова в системах счисления от 2 до 10
//Первый ввод - число, второй - система счисления
//Pascal ABC.NET v3.0

var
 a,i,b,r,n,j,bug:integer;
 s,se,slo,slof:string;

procedure preob(var a,b,n:integer; var se:string);
 begin
  repeat
   b:=a mod n;
   a:=a div n;
   str(b,se);
   s+=se;
  until (a<=n-1);
 end;

begin
readln(slo);
readln(n);
for j:=1 to length(slo) do
begin;
a:=ord(slo[j]);
preob(a,b,n,se);
str(a,se);
s+=se;
for i:=1 to length(s) div 2 do
begin;
se:=s[i];
s[i]:=s[length(s)-i+1];
s[length(s)-i+1]:=se[1];
end;
write(s,'-');
slof:=slof+s;
delete(s,1,length(s));
end;
end.

//Слово Программа она кодирует как 11001111-11110000-11101110-11100011-11110000-11100000-11101100-11101100-11100000-
0,0(0 оценок)
Ответ:
gvg1971
gvg1971
12.07.2020 00:22

1 - True/False

2 - логическая операция, которая объединяет два высказывания в одно новое, которое будет являться истинным тогда и только тогда, когда оба исходных высказывания ложны.

3 - Конъюнкция

4 - X И Y И Z

5 - OR

6 - 1. Инверсия;

2. Конъюнкция;

3. Дизъюнкция;

4. Импликация;

5. Эквивалентность.

7 - логическая операция, которая преобразует исходное высказывание в новое, значение которого противоположно исходному.

8 - Импликация

9 - логическая операция, которая объединяет два высказывания в одно новое, которое будет являться истинным тогда и только тогда, когда оба исходных высказывания истинны

10 -  Конъюнкция

11 - ?

12 - ?

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота