В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
bikosh02
bikosh02
22.10.2022 11:42 •  Информатика

Записать блок-схему и программу к задаче НАДО НУЖНО СДЕЛАТЬ ПРОГРАММУ С циклом с заданным числом повторений (циклы с параметром)

С клавиатуры вводятся 5 трехзначных чисел. Написать программу, в которой определяется и выводится на экран их сумма. Примечание: выполнять проверку является ли введенное число трехзначным или нет НЕ НАДО. Обратите внимание на формат данных.

Входные данные Результат на экране Введите 5 трехзначных чисел через пробел: 121 100 228 500 100 Сумма этих чисел равна 1049

Показать ответ
Ответ:
Granger341
Granger341
07.02.2020 22:35

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   int n;

   cin >> n;

   vector<int> v(n);

   for (int i = 0; i < n; ++i){

       cin >> v[i];

   }

   for (int i = 0; i < n; ++i){

       bool flag = false;

       for (int j = 0; j < i; ++j){

           if (v[i] == v[j]){

               flag = true;

           }

       }

       for (int j = i + 1; j < n; ++j){

           if (v[i] == v[j]){

               flag = true;

           }

       }

       if (flag == false){

           cout << v[i] << " ";

       }

   }

   return 0;

}

Объяснение:

0,0(0 оценок)
Ответ:
Nejdan1
Nejdan1
29.07.2020 19:31

Відповідь:

ответ дан на фото.

Ошибки:

Строка №4 у тибя на фото

(K = N * P(a + b + c)) в питоне нужно

после переменной поставить что-то,

например какойто знак там * или /

Строка №5 (Print(k))

У тибя в 4 строке K большая буква

в 5 строке маленькая ето ошибка.

Примечания:

1.Перемение советую называть с маленькой буквы

например a, b, c, what, name, surname.

2.Функции (например: print, int, input)

тоже советую называть с маленькой буквы

3. Желательно не взаимодействовать с int и

float, тоисть не добавлять ни умножать int с float.

Чтобы исправить то нужно просто дописать float()

например n = float(int(input())).

(Если ты не знал то float - ето не целое число там 8.5,

8.75, 2. 51, а int - ето наоборот целое число например 5, 10, 15,

20, 21)


информатика а пд ЗДЕСЬ КАРОЧЕ ошибки нужно их исправить и говорить ответ правильно в программе Pytho
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота