В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Записать алгоритм и написать программу циклического перемещения влево значений между переменными а, b, c

Показать ответ
Ответ:
LEHA6712
LEHA6712
29.06.2020 18:33
Program gt;
var a,b,c,k:integer;
begin
read(k);
{k-на какое число шагов надо переместит числа a b c влево}
k:=k mod 3;
if(k=0)then writeln(a,' ',b,' ',c);
if(k=1)then writeln(b,' ',c,' ',a);
if(k=2)then writeln(c,' ',a,' ',b);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота